[lkml]   [2004]   [Apr]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Does OSS sound work in 2.6 or not?
Andre Tomt wrote:

> OSS works just fine here in 2.6, on all the machines I have. I don't use
> ALSA's OSS emulation layer, just the "native" OSS thats in the kernel.
> It's used just like in 2.4, same module names and all. No black magic
> involved.
Let me provide a bit more detail. I have machines with "Vortex
boomerang" sound cards. I have a 2.4 driver for same, for OSS, under
NDA. In 2.6 those cards appear to be supported in ALSA, but using the
OSS emulation everything seems to work except there isn't any sound.

I've had several people tell me that they are using OSS/2.6 without the
ALSA utilities. I just want to know if that's possible or not, the
people with the machines don't want ALSA for reasons I would call
pigheaded stupidity if they weren't paying me to say "personal
preference" ;-)

In any case, that's the question, can I get there from here? I can't use
just OSS, the Vortex drivers are in ALSA.

-bill davidsen (
"The secret to procrastination is to put things off until the
last possible moment - but no longer" -me
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:02    [W:0.082 / U:5.412 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site