[lkml]   [2004]   [Mar]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: ACPI battery info failure after some period of time, 2.6.3-x and up
    On 12:29 pm Mar 4 David Ford <> wrote:
    > powerix root # cat /proc/acpi/battery/BAT0/state
    > present: yes
    > ERROR: Unable to read battery status
    > powerix root # dmesg -c
    > ACPI-0279: *** Error: Looking up [BST0] in namespace,
    > AE_ALREADY_EXISTS ACPI-1120: *** Error: Method execution failed
    > [\_SB_.BAT0._BST] (Node e7bd7680), AE_ALREADY_EXISTS
    > powerix root # uname -r
    > 2.6.4-rc1
    > This has been going on since about 2.6.3-rc something. Some while
    > after reading the /proc files, the ability to read the battery
    > information gets munged.

    Same here on a Toshiba 1410-s173 noteboook:

    [logger] ACPI group battery / action battery is not defined
    [kernel] ACPI-0279: *** Error: Looking up [BUFF] in namespace,

    I don't think it's happened in less than 24 hours of uptime, during which
    everything is good. I have been using suspend to ram daily if that matters
    (echo 3 > /proc/acpi/sleep).

    Linux version 2.6.3-wolk1.0 (root@jackass) (gcc version 3.3.3 20040217
    (Gentoo Linux 3.3.3, propolice-3.3-7)) #1 Thu Feb 26 16:18:24 CST 2004

    \__ Jason Munro

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:01    [W:0.021 / U:1.500 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site