lkml.org 
[lkml]   [2004]   [Feb]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: FATAL: Kernel too old
On Sat, 7 Feb 2004, Andrew Walrond wrote:

> I have seen this message when trying to use a glibc configured with
> --enable-kernel=2.4.20
> on a machine running a 2.4.19 kernel.
>
> You haven't either upgraded glibc or started using an older kernel, have you?

I think it also happens if you run a binary compiled on a
machine with such a glibc on another which has an older kernel
or the same glibc, but compiled with no --enable-kernel or an
older version set.

Can't test it, but:

My glibc was compiled with --enable-kernel=2.4.5.

A binary compiled with it:

% file /usr/bin/lsattr
/usr/bin/lsattr: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.4.5, dynamically linked (uses shared libs), stripped

A binary that came with the default glibc:

% file /usr/bin/ansi2knr
/usr/bin/ansi2knr: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.0.0, dynamically linked (uses shared libs), stripped

Yes, the default glibc was compiled without --enable-kernel, so
is compatible with >= 2.0.0.

Anyway, not a kernel problem. I have also seen it when trying
to emulate my binaries on FreeBSD, which has compatibility set
to... 2.4.2.

--
http://www.pervalidus.net/contact.html
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:00    [from the cache]
©2003-2011 Jasper Spaans