lkml.org 
[lkml]   [2004]   [Feb]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: 2.6.3-mm3 hangs on boot x440 (scsi?)
From
Date
On Tue, 2004-02-24 at 17:06, Andrew Morton wrote:
> john stultz <johnstul@us.ibm.com> wrote:
> >
> > Booting 2.6.3-mm3 on an x440 hangs the box during the SCSI probe after
> > the following:
> >
> > scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
> > <Adaptec aic7899 Ultra160 SCSI adapter>
> > aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs
> >
> >
> > I went back to 2.6.3-mm1 (as it was a smaller diff) and the problem was
> > there as well.
>
> Could you try reverting aic7xxx-deadlock-fix.patch? Also, add
> initcall_debug to the boot command just so we know we aren't blaming the
> wrong thing.

I was suspecting that patch, unfortunately reverting it doesn't seem to
help.

Here's the initcall_debug output:

ide-floppy driver 0.99.newide
calling initcall 0xc04d6821
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
<Adaptec aic7899 Ultra160 SCSI adapter>
aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

> Apart from that, gosh. Maybe you could add just linus.patch and
> bk-scsi.patch, see if that hangs too? Or just test the latest linus tree -
> the scsi changes were merged this morning. Thanks.

The bk.current that I tested and worked was from about two hours ago.
But I'll spin it again as 4 new changesets have shown up.

thanks
-john

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:01    [from the cache]
©2003-2011 Jasper Spaans. Advertise on this site