lkml.org 
[lkml]   [2004]   [Feb]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectSUB memeory stick and kobject oops
From
Date
Caught this one in my log when inserting my shiny new 512Mb Verbatim
USB memory stick:

usb 3-1: new high speed USB device using address 2
SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: Verbatim Model: USB Drive Rev: 2.00
Type: Direct-Access ANSI SCSI revision: 02
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
drivers/usb/core/usb.c: registered new driver usb-storage
USB Mass Storage support registered.
sda: Unit Not Ready, sense:
Current : sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sda : READ CAPACITY failed.
sda : status=1, message=00, host=0, driver=08
Current sd: sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sda: assuming Write Enabled
sda: assuming drive cache: write through
SCSI device sda: 1024000 512-byte hdwr sectors (524 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
SCSI device sda: 1024000 512-byte hdwr sectors (524 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda: sda1
sda: sda1
kobject_register failed for sda1 (-17)
Call Trace:
[<c01b5e83>] kobject_register+0x50/0x52
[<c01840f0>] add_partition+0xb4/0xde
[<c018426a>] register_disk+0xf8/0x103
[<c0202351>] add_disk+0x3b/0x48
[<c02022f4>] exact_match+0x0/0xb
[<c02022ff>] exact_lock+0x0/0x17
[<f09b5730>] sd_probe+0x1ff/0x36a [sd_mod]
[<c01853ab>] create_dir+0xa4/0xa6
[<c01fb493>] bus_match+0x35/0x5e
[<c01fb5a0>] driver_attach+0x55/0x7f
[<c01b5e56>] kobject_register+0x23/0x52
[<c01fb81a>] bus_add_driver+0x8d/0x9f
[<c01fbba0>] driver_register+0x2b/0x2f
[<f096c02d>] init_sd+0x2d/0x6b [sd_mod]
[<c0136fc3>] sys_init_module+0x107/0x23d
[<c027b736>] sysenter_past_esp+0x43/0x65

Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0

Gentoo 1.4 (unstable), kernel 2.6.3-mm2 and config is here:
[unhandled content-type:application/octet-stream]
Device seems to work after this though, it can be mounted as
/dev/sda1.

mvh,
A
--
Alexander Hoogerhuis | alexh@ihatent.com
CCNP - CCDP - MCNE - CCSE | +47 908 21 485
"You have zero privacy anyway. Get over it." --Scott McNealy
\
 
 \ /
  Last update: 2005-03-22 14:01    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site