lkml.org 
[lkml]   [2004]   [Nov]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Network slowdown from 2.6.7 to 2.6.9
I tried the new e1000 driver with TSO off and tcp_rmem set to a max of 
1000000 (I am sure the problem is reading and not writing). It had no
effect. The TCP traffic on the system is via RCP calls to port 388.
Any other ideas?
Stephen Hemminger wrote:

>On Mon, 22 Nov 2004 15:38:16 -0800
>Harry Edmon <harry@atmos.washington.edu> wrote:
>
>
>
>>Tried them all - none of them helped. Use "ntop" I can see that my
>>throughput on the Intel gigabit ethernet interface on the system maxes
>>out at 15.2 Mbps with 2.6.9. With 2.6.7 it made it to 35 Mbps.
>>
>>Does anyone have any other suggestions as to what to look for to
>>diagnose this problem?
>>
>>
>
>Well, before the TSO changes, if TSO was enabled then TCP would not obey slow
>start or do congestion control properly. Did you increase the TCP send/receive
>buffers (sysctl's net.ipv4.tcp_rmem and net.ipv4.tcp_wmem)? You may just
>be window limited. Also, 2.6.9 has TCP bugs with TSO that can cause panic's.
>These have been fixed in 2.6.10-rc2.
>
>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:08    [W:0.196 / U:0.592 seconds]
©2003-2011 Jasper Spaans. Advertise on this site