[lkml]   [2004]   [Nov]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 3/13] Filesystem in Userspace
On Sünndag 21 November 2004 01:34, Miklos Szeredi wrote:
> > If something it's in mainline "kernel version 2.6.56" is enought to describe
> > what code people are running.
> It's not for people, but for the library.  It's the version of the
> userspace-kernel interface.
But once it is integrated, you can no longer make incompatible changes to
the API. You only need to know the difference between each API version
prior to the inclusion and the final version.

If the API gets extended later, any user should be able to deal with the
extension failing on older kernels.

Arnd <><
[unhandled content-type:application/pgp-signature]
 \ /
  Last update: 2005-03-22 14:08    [W:0.039 / U:6.824 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site