[lkml]   [2004]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [Linux-fbdev-devel] Help re Frame Buffer/Console Problems
    On Tuesday 02 November 2004 01:32, Mark Fortescue wrote:
    > Hi all,
    > Thanks for the info Antonino. I see you spotted my typing error. Yes it is
    > the 2.6.10-rc1-bk6 kernel. The oter error is the It should be
    > The cgthree driver does not currently set up the all->,
    > all-> or all-> structures. Putting a value of 8
    > in the length field of these structures (correct for the cgthree) does get
    > me my logo back but I am still getting black on black text. It makes it
    > very difficult to read. It is begining to look like there is something
    > werid going on with the colour pallet stuf for PSEUDO_COLOUR.

    I doubt that the problem is at the driver layer since you were able to
    see the logo. It's probably higher up.

    Try this mod, hardwire the foreground color to 0x07.

    Edit drivers/video/console/bitblit.c:bit_putcs() and change this line:

    image.fg_color = fg;
    image.bg_color = bg;


    image.fg_color = 0x07070707;
    image.bg_color = 0x0;

    You can also try the reverse:

    image.fg_color = 0x0;
    image.bg_color = 0x07070707

    If you get visible text, the problem is either in fbcon.c or vt.c.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:07    [W:0.047 / U:5.136 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site