lkml.org 
[lkml]   [2004]   [Jan]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] 2.6.1-rc2 ide barrier support
On Wed, Jan 07 2004, Bartlomiej Zolnierkiewicz wrote:
> On Wednesday 07 of January 2004 14:43, Jens Axboe wrote:
> > Bart, would you care to review the ide bits for sanity?
>
> Yep, here is just a first sight...
>
> > + struct request *flush_rq = &HWGROUP(drive)->wrq;
>
> I want to remove drive->wrq in the future.

Yes I've wanted that, too, but only because of the ugly (and often racy)
multimode crap. I'm just considering wrq a 'reserve rq' to be used where
you cannot reliably get a new request atomically.

I'm open to any better ideas you have for this...

> > + memset(drive->special_buf, 0, sizeof(drive->special_buf));
> > +
> > + ide_init_drive_cmd(flush_rq);
> > +
> > + flush_rq->flags = REQ_DRIVE_TASK;
> > + flush_rq->buffer = drive->special_buf;
> > + flush_rq->special = rq;
> > + flush_rq->buffer[0] = WIN_FLUSH_CACHE;
> > + flush_rq->nr_sectors = rq->nr_sectors;
>
> I think you should try use REQ_DRIVE_TASKFILE,
> instead of adding drive->special_buf.

How does that change anything? I still need a command buffer, if I use
REQ_DRIVE_TASKFILE I need an even bigger one.

> > +/*
> > + * FIXME: probably move this somewhere else, name is bad too :)
> > + */
> > +static sector_t ide_get_error_location(ide_drive_t *drive, char *args)
>
> This is probably useful in few other places.

Yeah, as the comment states I know it's not really in the right place.
Where do you want it? And any suggestions for a better name? :)

--
Jens Axboe

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:59    [W:0.107 / U:0.300 seconds]
©2003-2014 Jasper Spaans. Advertise on this site