[lkml]   [2004]   [Jan]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    Subjectno ALSA sound in 2.6 on Intel 82801CA-ICH3 - OSS works
    I'm a bit ashamed about posting this, but I couldn't find anyone with
    a similar problem googling. I admit up front that I'm ALSA-ignorant
    so this could well be a silly configuration issue...

    This is a Dell Latitude C640 with

    00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio (rev 02)

    I tried using ALSA in kernel or modular, but the three apps I use
    (xmms, xine and gmplayer) all report -ENODEV on /dev/dsp. This is
    /var/log/messages with in-kernel ALSA:

    Dec 28 10:53:41 incident kernel: Advanced Linux Sound Architecture Driver Version 0.9.7 (Thu Sep 25 19:16:36 2003 UTC).
    Dec 28 10:53:41 incident kernel: intel8x0: clocking to 48000
    Dec 28 10:53:41 incident kernel: ALSA device list:
    Dec 28 10:53:41 incident kernel: #0: Intel 82801CA-ICH3 at 0xd800, irq 11

    and the card appears to be properly detected under /proc/asound;
    this is the output when loaded as modular:

    [asuardi@incident asound]$ ls
    card0 cards devices I82801CAICH3 oss pcm timers version
    [asuardi@incident asound]$ cat devices
    0: [0- 0]: ctl
    25: [0- 1]: digital audio capture
    16: [0- 0]: digital audio playback
    24: [0- 0]: digital audio capture
    33: : timer
    [asuardi@incident asound]$ cat pcm
    00-00: Intel ICH : Intel 82801CA-ICH3 : playback 1 : capture 1
    00-01: Intel ICH - MIC ADC : Intel 82801CA-ICH3 - MIC ADC : capture 1
    [asuardi@incident asound]$ cat timers
    G0: system timer : 1000.000us (10000000 ticks)
    G1: RTC timer : 976.562us (100000000 ticks)
    P0-0-0: PCM playback 0-0-0 : SLAVE
    P0-0-1: PCM capture 0-0-1 : SLAVE
    P0-1-1: PCM capture 0-1-1 : SLAVE
    [asuardi@incident asound]$ cat version
    Advanced Linux Sound Architecture Driver Version 0.9.7 (Thu Sep 25 19:16:36 2003 UTC).
    Compiled on Jan 3 2004 for kernel 2.6.1-rc1.

    Using i810_audio from OSS just works; in 2.4 I've always been
    using OSS successfully, ALSA never worked in any 2.5.x I've

    Thanks in advance,


    "Immagina intensamente e vedrai
    dove gli altri pensano che non ci sia niente"
    (Cristina Dona', "Salti nell'aria")

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:59    [W:0.022 / U:31.144 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site