[lkml]   [2004]   [Jan]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [2.6.1] fbdev console: can't load vga=791 and yes vga=ask!
    On 27/01/2004 at 18:59, Xan wrote:

    > I did _not_ booted fine. I tried if with vga=795 it booted fine as you and the
    > same result as 791 obtained: black screen until X window appears. When I
    > switch to pty, black screen or color (and deformed) puzzle of X window
    > contain.

    In 2.6.1 I could use framebuffer through vesafb just with that parameter
    (vga=795, ie. 1280x10224 16M).

    In 2.6.2-rc* it does not work for me, just blank screen if I try to use

    Zack Winkles pointed me that I could try passing
    video=vesafb:ywrap,pmipal,mtrr,vga=795 to get vesafb working.

    Thanks for it. Right now I'm on travel and I can not try it, I will be
    able to do so on thursday.

    > It's rare thing: I could promise that I compiled 2.6.0 with the same
    > configuration and it worked.

    I did not try 2.6.0 with that radeon 9200 (I didn't have it then).
    vesafb stopped working for me in 2.6.2-rc1.

    > Can you explain me what means 791, 795, ... and what number belongs to
    > 1024x768 and 16 colors, and if 800x600 and 256?...

    You can see it in Documentation/fb/vesafb.txt (that file has the numbers
    in hexadecimal, and kernel wants the boot parameter in decimal, just
    convert it).

    Althoug, I would prefer to use radeonfb instead of vesafb (radeonfb
    turns off my monitor and vesafb does not).

    Anyone with a Radeon 9200 does use radeonfb ? If yes, any special boot

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:00    [W:0.028 / U:177.508 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site