lkml.org 
[lkml]   [2003]   [Sep]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [2.6.0-test4] [BUG, ALSA] no 44.1KHz sound for i8x0 ICH2...
At Mon, 8 Sep 2003 11:33:58 +0200 (MEST),
Daniel Blueman wrote:
>
> I can't get any sound output with an Intel 815 chipset at 44.1KHz. ALSA
> reports the sound chipset can clock to 41KHz.
>
> What information do I need to post here?
>
> Please CC me on any replies.
>
> --- [ lspci -v ]
>
> 00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio
> (rev 11)
> Subsystem: Dell Computer Corporation: Unknown device 00be
> Flags: bus master, medium devsel, latency 0, IRQ 10
> I/O ports at c800 [size=256]
> I/O ports at cc40 [size=64]
>
> --- [ dmesg ]
>
> Advanced Linux Sound Architecture Driver Version 0.9.6 (Wed Aug 20 20:27:13
> 2003 UTC).
> PCI: Found IRQ 10 for device 0000:00:1f.5
> PCI: Sharing IRQ 10 with 0000:00:1f.3
> PCI: Setting latency timer of device 0000:00:1f.5 to 64
> hub 1-0:0: debounce: port 1: delay 100ms stable 4 status 0x301
> intel8x0: clocking to 41151 <----- should be 44100?

no, it doesn't mean that the chip supports 44.1kHz.
it shows that your sound chip is driven in the detected clock.
usually it's 48000, but in some cases, it's based on PCI clock and
runs in different speed.
or, it could be a bug of detection routine, which might be influenced
by cpufreq, etc.

if the sound is too slow, please give the option ac97_clock=48000
manually.


--
Takashi Iwai <tiwai@suse.de> SuSE Linux AG - www.suse.de
ALSA Developer ALSA Project - www.alsa-project.org
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:48    [from the cache]
©2003-2011 Jasper Spaans