lkml.org 
[lkml]   [2003]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: C99 Initialisers
Randy.Dunlap wrote:
> On Tue, 12 Aug 2003 20:02:03 -0400 Jeff Garzik <jgarzik@pobox.com> wrote:
>
> | Greg KH wrote:
> | > In the end, it's up to the maintainer of the driver what they want to
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> | > do. So, Jeff and David, here's a patch against the latest 2.6.0-test3
> | > tg3.c that converts the pci_device_id table to C99 initializers. If you
> | > want to, please apply it.
>
> I strongly agree with Greg's comment above.
> |
> | it expands a few lines to a bazillion :( I would rather leave it as
> | is... you'll find several PCI ethernet drivers with pci_device_id
> | entries that fit entirely on one line, and I think that compactness has
> | value at least to me.
>
> However, I would change for readability. Maybe not my readability,
> but for all others who read and try to help maintain all of Linux
> source code.


I find the compact form quite readable, and comfortable on the eyes.
Users don't seem to complain, either. I get compact-form pci_device_id
patches from Joe Sixpack quite often :)

Expanding this device id struct to use C99 initializers isn't terribly
scalable: once you get past just a few ids, you bloat up the source
code considerably. I would much rather move the PCI ids out of the
drivers altogether, into some metadata file(s) in the kernel source
tree, than bloat up tg3, tulip, e100, and the other PCI id-heavy
drivers' source code.

Jeff



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.131 / U:0.088 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site