lkml.org 
[lkml]   [2003]   [Jul]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Kernel 2.6.0-test1-ac3: alsa snd_via82xx
Hello Takashi!


Takashi Iwai wrote:
> > I figured out some strange behaviour of the alsa drivers in kernel
> > 2.6.0-test1-ac3.
> > When compiling everything into the kernel (=y), I was not able to get
> > sound out of my machine at all. But with CONFIG_SND_VIA82XX=m it worked.
> > Isn't that strange?
>
> what do you mean exactly "no sound"? you can play the file but no
> sounds come out, or playback is not operational?

I mean, that it looked all good, the driver seemed to be operational,
but I did not get any Sound out of it. I stress, that this only happened
when everything was compiled into the kernel. Therefore, I did not use
a special modprobe.conf or such.

Now that it works, I can try again to compile everyting into the kernel
to do a second check. I will do later today and let you know the
results.

> did you set any module options for ALSA in /etc/modprobe.conf?
at first none, and now this:

# This file was automatically generated by alsa-base's debconf stuff
alias char-major-116 snd
alias char-major-14 soundcore

options snd major=116 cards_limit=4 device_mode=0660 device_gid=29 device_uid=0

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias snd-card-0 snd-via82xx

alias snd-slot-0 snd-card-0
alias sound-slot-0 snd-slot-0


Regards, claas
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.114 / U:0.080 seconds]
©2003-2011 Jasper Spaans. Advertise on this site