lkml.org 
[lkml]   [2003]   [Jul]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.0-test2 has i8042 mux problems
* dean gaudet <dean-list-linux-kernel@arctic.org> [030728 04:13]:
> i've got a box on which 2.4.x works fine, but 2.6.0-test2 gets into a snit
> when it's trying to initialize the i8042. i can get 2.6.0-test2 to boot
> if i add "i8042_nomux".
>
> the mux initialization code seems kind of ... wonk -- it seems to write
> values to the registers then read back and if the value is the same then
> it assumes the mux is there. that seems way too likely to be broken in
> situations when the mux isn't there... it'd be better to be looking for
> some value which is different after writing.
>
> the southbridge in this system is the ali1563. if it helps i can supply a
> complete trace of in/out on ports 0x60 and 0x64.

I can confirm this. I have an Amilo A laptop with the following sb:
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]

without "i8042_nomux" the keyboard is recognized fine, but no mouse is
found on the mux. With the option everything works fine.

Stepan


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.238 / U:0.436 seconds]
©2003-2011 Jasper Spaans. Advertise on this site