lkml.org 
[lkml]   [2003]   [Jul]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    Subject[DAC960] 2.6.0-test1: device files wrong in devfs
    When I mount devfs in 2.6.0-test1 (and -bk2), I have the following 
    DAC960-related files in /dev (actually, /mnt/dev) without devfsd:

    /dev/part{1,2,5,6,7}
    /dev/disc
    /dev/discs/disc[0-31] (these 32 files are symlinks to "../")

    I don't have a /dev/rd/ directory. All other files in /dev seem to be
    in the right place. The relevant lines from dmesg:

    DAC960#0: /dev/rd/c0d0: RAID-5, Online, 88442880 blocks, Write Back
    devfs_mk_dir: invalid argument.<6> rd/c0d0: p1 p2 < p5 p6 p7 >
    devfs_mk_dir: invalid argument.<4>devfs_mk_bdev: could not append to
    parent for /disc (this line shows up 31 times in a row)

    AFAIK, the last correctly working kernel is 2.5.67. 2.5.68 doesn't
    work, however I don't know if that's because of the same problem.

    My hardware:
    Mylex ExtremeRAID 1100 (DAC1164P)
    ALR Revolution 6x6 (Intel 450GX-based Pentium Pro mainboard)
    6x Intel PII Overdrive CPU
    4 GB mem

    FWIW, the problem also occurs when I _don't_ enable highmem support.

    Please CC replies to lkml@gert.robben.nu (I'm not subscribed).

    Thanks,

    Gert Robben
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:47    [W:0.050 / U:59.492 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site