[lkml]   [2003]   [Jul]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: 2.6.0-test1-mm2 music skips
At Sun, 20 Jul 2003 21:21:43 -0400,
Ed Sweetman wrote:
> Christian Axelsson wrote:
> > On Sun, 2003-07-20 at 22:34, Lukas Kolbe wrote:
> >
> > Please read the O*int threads.
> > It's probably Con's new scheduler that is causing these problems.
> > If you are using alsa, try the OSS emulation as it seems to help abit.
> >
> I've been using the 2.5 kernel for a long time now and the 2.4 kernel
> since it was just turned into 2.3. There have been these "problems"
> since 2.3, this is not something new caused by any new schedulers. The
> schedulers can cause problems, no doubt, but they also make userspace
> programming issues apparent. The fact that going to oss emu only proves
> that this is mostly a userspace problem. ALSA drivers have to be coded
> with much more attention to latency because it's very specific about
> being run on time. You can only send it a small amount of data every
> write you make to the soundcard.

well, just a small correction: it's ALSA output plugin of xmms, not
ALSA drivers. it uses the hardware buffer directly (or mmapped) while
xmms OSS output plugin has much larger internal buffers.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:47    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean