lkml.org 
[lkml]   [2003]   [Jul]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: IDE/Promise 20276 FastTrack RAID Doesn't work in 2.4.21, patchattached to fix

On Sat, 12 Jul 2003, Ruth Ivimey-Cook wrote:

> On Saturday 12 Jul 2003 5:14 pm, Bartlomiej Zolnierkiewicz wrote:
> > I think you just need "pdc_ide=0,force" and "pdc_ide=0,noforce".
> > No need to complicate things.
> > Remember that ataraid is only software RAID driver and pdc202xx_new
> > is a chipset driver.
>
> I am not forgetting, but I don't like this idea of 'force' -- it instantly
> raises the question 'force what' and then you're in the quagmire again.

"force" means only use pdc202xx_old/new driver even if controller was
marked as disabled by BIOS (on-board or on-card).

> Better to tell the kernel what you want and let the kernel worry about how to
> make it happen.
>
> So the "pdc_ide2=jbod" would be scanned and interpreted as a request to
> activate ('force') the drive into IDE mode and not enable any ataraid (jbod
> ==> just disks),
>
> while "pdc_ide3=promise" would let the drive state be, and make the kernel do
> a "modprobe promise-ft" (or whatever it's called) to load the rest of the
> driver, as is done for 'scsi-hostadapter'. [Would you ever have to force a
> promise chip into promise-raid mode?].
>
> Do you see what I mean?
>
> If you prefer, the string could be "pdc=ide2:ide, ide3:ataraid".
>
> > jbod/raid should be managed by ataraid driver not ide or pdc202xx_new.
>
> I was using jbod as just that, not as meaning raid-0 or similar. Perhaps I
> should have been clearer. So you've a choice of (just IDE), (RAID via
> ataraid) and (RAID via Promise)

Once again, I don't care unless ataraid is ported to 2.5.
We can discuss this then.

> > And seriously, I don't care unless somebody ports ataraid to 2.5.
> > [ Hint, hint! ;-) ]
>
> Hint understood and I'll look, but I'm no kernel guru.
>
> > > Should I think about coding this?
> >
> > No, think about porting ataraid and pdcraid to 2.5 first.
>
> pdcraid == ataraid module for PDC?? Haven't looked at the src yet.
>
> Regards,
>
> Ruth
>
>
> --
> Engineer, Author and Webweaver

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:46    [from the cache]
©2003-2011 Jasper Spaans