lkml.org 
[lkml]   [2003]   [Jun]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [BUG]: problem when shutting down ppp connection since 2.5.70
    On Mon, 30 Jun 2003 10:02:42 -0400
    Chris Friesen <cfriesen@nortelnetworks.com> wrote:

    > Paul Mackerras wrote:
    >
    > > Is this the user-mode pppoe or the in-kernel pppoe? IOW, are you
    > > using the pppoe channel type, or do you have the usermode program that
    > > runs pppd behind a pty?
    >
    > I believe its the Roaring Penguin usermode one. I'm fairly sure PPPOE
    > isn't enabled in the kernel. I'm at work now, so it'll have to wait
    > till this evening to make sure.
    >
    > > And, do you have any TCP connections open over the link when you take
    > > it down?
    >
    > On at least some of the occasions there should have been no connections
    > open as the machine had just booted and the first thing I did after X
    > came up was to shutdown adsl.
    >
    > > What version of pppd is it?
    >
    > Not sure--will check later. Pretty sure its Mandrake 9 default.
    >
    > > Has anyone been able to replicate this without using pppoe? The type
    > > of channel shouldn't make any difference, but I just tried ppp over a
    > > pty and it worked fine (except that Deflate is broken, but that's
    > > another problem).
    >
    > Note that I can only reliably reproduce it if the dsl connection is
    > brought up at init time. If I don't bring it up automatically at init
    > but manually bring it up later, the problem doesn't seem to occur.
    >
    > Chris

    PPP did have problems keeping track of the tty until the latest round
    if fixes (2.5.73+). The ppp_async module wasn't using owner fields as
    reqired.


    Also, see if bringing down the ppp connection with ifconfig
    before attempting the rmmod helps. i.e.
    ifconfig ppp0 down
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:46    [W:0.023 / U:3.272 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site