lkml.org 
[lkml]   [2003]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH] Fix .altinstructions linking failures
On Tue, May 06, 2003 at 09:56:14PM +0200, Andi Kleen wrote:
> The driver is buggy. The #ifdef MODULE needs to be removed and proc_cpia_destroy
> be marked __exit instead, then things will be ok.

FWIW I compiled a "maxi kernel" now (with everything that compiles compiled in)
and only cpia seems to have this bug. So with this patch things should be ok
again.

-Andi

Index: linux/drivers/media/video/cpia.c
===================================================================
RCS file: /home/cvs/linux-2.5/drivers/media/video/cpia.c,v
retrieving revision 1.25
diff -u -u -r1.25 cpia.c
--- linux/drivers/media/video/cpia.c 25 Apr 2003 05:41:01 -0000 1.25
+++ linux/drivers/media/video/cpia.c 6 May 2003 20:08:34 -0000
@@ -1409,12 +1409,10 @@
LOG("Unable to initialise /proc/cpia\n");
}

-#ifdef MODULE
-static void proc_cpia_destroy(void)
+static void __exit proc_cpia_destroy(void)
{
remove_proc_entry("cpia", 0);
}
-#endif /*MODULE*/
#endif /* CONFIG_PROC_FS */

/* ----------------------- debug functions ---------------------- */
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2005-03-22 13:35    [from the cache]
©2003-2011 Jasper Spaans