lkml.org 
[lkml]   [2003]   [May]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: The disappearing sys_call_table export.
On Thu, 15 May 2003, Chris Ricker wrote:

> On Thu, 15 May 2003, Jesse Pollard wrote:
>
> > On Wednesday 14 May 2003 16:32, Richard B. Johnson wrote:
> > > Not so, with the latest Red Hat distribution (9). You can no longer
> > > set init=/bin/bash at the boot prompt.... well you can set it, but
> > > then you get an error about killing init. This caused a neighbor
> > > a lot of trouble when she accidentally put a blank line in the
> > > top of /etc/passwd. Nobody could log-in. I promised to show her
> > > how to "break in", but I wasn't able to. I had to take her hard-disk
> > > to my house, mount it, and fix the password file. All these "attempts"
> > > at so-called security do is make customers pissed.
> >
> > I fix those errors with by booting the Slackware CD with the live
> > filesystem...
> >
> > No dependancies on any of the regular disks - then I can fix anything within
> > reason (haven't tried md raids though).
>
> You don't have to do that. Richard is mis-informed. Any of the following
> still work on Red Hat Linux 9:
>
> init=/bin/bash # drops you straight to a bash shell
> init 1 # runs runlevel 1 SysV init scripts and rc.sysinit
> init single # runs rc.sysinit, but not runlevel 1
> init emergency # runs a shell
>
> all without going to rescue media.
>

Bullshit. Try it. So called Linux 9 /Professional did **NOT** allow
anybody to break in. Maybe you didn't try it, or maybe it wasn't
tested in a machine that uses initrd to make the hard disk accessible,
but it absolutely positively fails to run any 'init' when the LILO boot
is interrupted and we entered, in addition to the linux OS label, the
parameter init=/bin/bash. We even tried, probably nearly a hundred
boots, over two days various things like init=/bin/csh.... various
possible shells, plus init=/sbin/init 1, etc. Any time 'init' was
defined on the boot command-line, the machine would panic with
'attempting to kill init'.
Also, when booting on the distribution media, the ALF-F2...F5 keys
no longer function so you can't access a shell. Try it before you
claim I'm "mis-informed". I wasted an entire weekend until I took
the damn hard disk out, brought it home, and "fixed" it.

Cheers,
Dick Johnson
Penguin : Linux version 2.4.20 on an i686 machine (797.90 BogoMips).
Why is the government concerned about the lunatic fringe? Think about it.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:35    [from the cache]
©2003-2011 Jasper Spaans