lkml.org 
[lkml]   [2003]   [Mar]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] Fixup warning for acenic
>> > 2.4.9 of course has the newstyle pci interface! And actual hotplug
>> > PCI support also is in all today singnificant 2.4.9 forks (RH..).
>> >
>> > There's even some shim to emulate the pci_driver style interface on
>> > 2.2.
>> >
>> > Anyway, this table has another use, it's used by userland ools like
>> > installers for selecting the right driver for a given pci device. So
>> > even if it seems unused from kernelspace it has a use.
>>
>> Are they kmem diving? Or parsing source code?
>
> They are looking at the modules.pcimap files which are generated from
> depmod, which pull it from the object files.

Hmmm ... so we're going to get a compiler warning for every hotpluggable
driver? or is this just an error in the way acenic does it? Seems like
the latter, but it's not clear to me how to fix it up properly ...
If it's the former, we need a better solution ;-)

M.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:34    [W:0.091 / U:0.228 seconds]
©2003-2014 Jasper Spaans. Advertise on this site