lkml.org 
[lkml]   [2003]   [Mar]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectModules broken on alpha ?
    From
    Date
    Richard, Rusty,

    I've been trying to use modules on alpha without much success (at
    least on the latest 2.5.63-bk). Any non-trivial module fails to load
    with a relocation error :

    little-time:~# lsmod
    Module Size Used by
    little-time:~# modprobe crc32
    little-time:~# lsmod
    Module Size Used by
    crc32 3456 0
    little-time:~# modprobe depca
    module depca: Relocation overflow vs section 17
    FATAL: Error inserting depca (/lib/modules/2.5.63-mod/kernel/drivers/net/depca.ko): Invalid module format
    little-time:~# modprobe 3c509
    module 3c509: Relocation overflow vs section 19
    FATAL: Error inserting 3c509 (/lib/modules/2.5.63-mod/kernel/drivers/net/3c509.ko): Invalid module format
    little-time:~# lsmod
    Module Size Used by
    crc32 3456 0
    little-time:~#

    I'm using module-init-tools from Debian sid (0.9.10-1).

    Any idea ?

    Thanks.

    M.
    --
    Places change, faces change. Life is so very strange.
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:33    [W:0.020 / U:63.368 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site