[lkml]   [2003]   [Feb]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: AGP aperture is 16MB @ 0x0
    On Sun, 2003-02-02 at 15:36, Gianni Tedesco wrote:
    > Hi,
    > I have a problem getting agpgart/drm to work on my TiBook, I have
    > tracked the problem down to that suspect looking message.
    > agpgart: AGP aperture is 16MB @ 0x00
    > [drm] AGP 0.99 on Unkiwn @ 0x00000000 16MB
    > which results in the following messages in my XFree86 logs:
    > [agp] ring handle = 0x0000000
    > [agp] Could not map ring

    Ok, things are a bit weird with UniNorth, AGP base beeing at 0
    is actually correct. You probably need fixed DRM which can deal
    with UniNorth weirdies. Ask Michel Dänzer <>
    for up to date patches against XFree DRI CVS

    > Its an ATI Radeon 7500 Mobility M7 on an Apple UniNorth 1.5 chipset.
    > I think the correct aperture base is one of:
    > AGP special page: 0xdffff000
    > aper_base: b8000000 MC_FB_LOC to: bbffb800, MC_AGP_LOC to: ffffc000

    No. These are addresses in the card's address space, and things are
    setup differently than what is displayed by this debug code actually ;)
    What you see there is what I would like to program in the card, but I
    had to disable this for now as it's incompatible with current XFree
    radeon driver.

    Benjamin Herrenschmidt <>
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:32    [W:0.020 / U:2.628 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site