lkml.org 
[lkml]   [2003]   [Feb]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH 2.5.62]: 2/3: Make SCSI low-level drivers also a seperate, complete selectable submenu
On Wed, Feb 19, 2003 at 08:55:22AM -0500, Bill Davidsen wrote:
> On Wed, 19 Feb 2003, Thomas Molina wrote:
>
> > On Tue, 18 Feb 2003, Bill Davidsen wrote:
> >
> > > On Tue, 18 Feb 2003, Christoph Hellwig wrote:
> > >
> > > > On Tue, Feb 18, 2003 at 02:02:10PM +0100, Marc-Christian Petersen wrote:
> > > > > so you can disable all SCSI lowlevel drivers at once.
> > > >
> > > > Why? just disable CONFIG_SCSI instead of adding an artifical option
> > >
> > > Isn't that going to disable all of SCSI? I think the intention may be to
> > > drop hardware drivers and just use ide-scsi, although I might be
> > > misreading the original intent.
> > >
> > > There are a fair number of tape/CD/DVD devices out there which you might
> > > run SCSI. I many cases will run SCSI or not at all.
> >
> > I thought the intent was to make it unnecessary to run ide-scsi at all.
>
> I don't think it matters, the idea is to avoid all the low-level SCSI
> menus in one place, without disabling the ability to handle ATAPI devices.
> Using the ide-scsi or not still uses SCSI drivers AFAIK.

But as far as linux scsi is concerned, ide-scsi is a low-level SCSI driver.

IDE and USB have there own Kconfig options that enable low-level SCSI
driver emulation outside of drivers/scsi, pcmcia does not, and there are
probably other exceptions.

The following is simpler, though I'm not suggesting anything like this be
applied, since we don't have consitency. If all of the low-level scsi
drivers and options were under drivers/scsi, and we could separate
emulated versus real, something like this might be OK:

--- 1.12/drivers/scsi/Kconfig Sun Feb 9 17:29:49 2003
+++ edited/drivers/scsi/Kconfig Wed Feb 19 10:19:11 2003
@@ -170,8 +170,16 @@
logging turned off.


+config SCSI_LOW_LEVEL
+ bool "SCSI low level drivers"
+
+ help
+ enables a list of additional SCSI low level drivers
+
+ If you need one of the drivers here say Y, else say N ;-)
+
menu "SCSI low-level drivers"
- depends on SCSI!=n
+ depends on SCSI!=n && SCSI_LOW_LEVEL!=n

config SGIWD93_SCSI
tristate "SGI WD93C93 SCSI Driver"
-- Patrick Mansfield
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [from the cache]
©2003-2011 Jasper Spaans