[lkml]   [2003]   [Feb]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRE: 2.5 AGP for 2.4.21-pre4

Hash: SHA1
You patch deleted the definitions for the Via chipsets. After I added them
back the agpgart driver appeared to load correctly. When I try to start X I
get a black screen and have to shutdown and reboot to get video back. This
is with an AIW 9700 Pro and a Gigabyte GA-7VAXP KT400 based motherboard .

- -- Edward Killips

- -----Original Message-----
[]On Behalf Of Brian Jackson
Sent: Saturday, February 15, 2003 10:35 PM
Subject: 2.5 AGP for 2.4.21-pre4

This is a poor attempt at a backport of the 2.5.61 AGP subsystem by someone
who doesn't know what he is doing and is in way over his head. That said,
there any "brave" souls out there that want to try this out with an AGP3
and 2.4.21pre4. I compile/boot tested it with an old ati card, but I don't
have an AGP 3.0 card/MB to test it on. I got into X and ran glxgears using
this kernel(I am using it to finish writing this email)

agp has to be built in to the kernel (no modules)

I did the following:
copied the drivers/char/agp directory from 2.5.61
copied include/asm-*/agp.h from 2.5.61
copied include/linux/*agp.h from 2.5.61
made some changes to drivers/char/agp/Makefile
on line 619&635 of frontend.c changed remap_page_range to only have 4
line 705 generic.c changed SetPageLocked -->SetPageReserved
(not sure if this is right, but Locked doesn't exist in 2.4 and I thought
Reserved might work -- Let me know if this should be something else)
backend.c:241 & backend.c:263 commented references to 2.5 module stuff
(therefore this only safe to be built into the kernel for now, any ideas
I should use here instead?)
added some device id's to drivers/char/agp/agp.h from
uninclude gfp.h & linux/page-flags.h from amd-k7-agp.c
What else I need to do:
change to old style module init stuff

This is nowhere near suitable for production use, but I would like some
that actually have AGP3 cards/MB's to try this out

- --Brian Jackson

P.S. All criticism is welcome even flaming since I am in a decent mood right

P.S.S. To Dave Jones -- I thought 2.5 had support for VIA chipsets & AGP3,
I only saw config options for the 7205/7505

- -
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at
Version: PGP 8.0
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:33    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean