lkml.org 
[lkml]   [2003]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [2.6] Missing L2-cache after warm boot
Date
On Tuesday 02 Dec 2003 13:26, Jochen Hein wrote:
> Ian Hastie <ianh@iahastie.clara.net> writes:
> > On Monday 01 Dec 2003 14:04, Jochen Hein wrote:
> >> I'm running 2.6.0-test11 on an older Thinkpad 390E,
> >> When booting into 2.6.0-test11 after running Windows2000 I get:
> >
> > Do any of the previous test releases show this problem?
>
> -test11 is the first release running on that machine. My older TP600
> destroyed its WIndows 95 so I got a replacement. Compiling a kernel
> takes an hour or two, so it is not much fun trying different kernels.

No faster machine to compile on? Still think this isn't a kernel problem
anyway.

> > If it's
> > via the BIOS then does that show the L2 cache as being present?
>
> The BIOS doesn't tell anything, the setup doesn't have a "cache
> enable" or "turbo" entry.

I was just hoping it would have a configuration screen shown after POST. I
had expected that it would show any active caches. Doesn't seem so likely
now though. *8/

> > My immediate thought was a BIOS problem. IBM's web site doesn't say any
> > BIOS updates fix L2 cache related problems, but then it doesn't seem to
> > use technical descriptions like that. It says the latest BIOS is 1.55 -
> > R01_C9.
> >
> > http://www-1.ibm.com/support/docview.wss?rs=0&uid=psg1MIGR-4F3VKB&loc=en_
> >US
>
> I'll see what BIOS I have - it is the latest. Thanks for the hint anyway.

OK. *8)

> > Or maybe it's possible that something in MS Windows 2000 is turning off
> > the L2 cache and it isn't getting reactivated by the warm boot?
>
> Is there any way to see what Windows does here? I only found a manual
> enable of the L2cache when using older processors.

Who knows what a Windows programme or driver might do in order to "fix" some
problem? I suppose it's possible that a programme like SiSoft Sandra might
be able to tell if the L2 cache is active or not. There is almost bound to
be some programme that can read the appropriate configuration bits.

> > What happens when
> > you do a cold boot to Linux then reboot from there?
>
> That is fine.
>
> For now the system seems to be fine, even when starting from Win2k via
> BIOS reboot. Hmpf.

Annoying. Can you think of anything you might have done with Windows 2000, eg
programme run or device used, that you haven't done when testing?

--
Ian.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:59    [W:0.282 / U:0.428 seconds]
©2003-2014 Jasper Spaans. Advertise on this site