lkml.org 
[lkml]   [2003]   [Nov]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [BUG] Ricoh Cardbus -> Can't get interrupts



    On Mon, 24 Nov 2003, Jean Tourrilhes wrote:
    >
    > I have a new Ricoh PCI-Carbus bridge and the kernel
    > 2.6.0-test9 doesn't seem to configure it properly (see below).

    Have you tried with ACPI? And conversely, if you're already using ACPI for
    PCI irq routing, have you tried with "pci=noacpi"?

    Basically, it looks like there is no irq routing information for the chip.
    Which is deadly for any PCI device - we can figure out pretty much
    everything else, but not the irq.

    We don't ever try to autoprobe for PCI interrupts, because it's fragile
    and tends to cause lockups on any hardware where the irq is shared with
    something else. So PCI devices require irq routing information somewhere
    (usually PIRQ table in the BIOS or the ACPI tables).

    Linus
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2009-11-18 23:46    [W:0.042 / U:4.580 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site