lkml.org 
[lkml]   [2003]   [Nov]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [linux-usb-devel] [BUG] Still having problems with an USB Drive
Alan Stern wrote:
> On Thu, 13 Nov 2003, Rogério Brito wrote:
>
>
>>Yes, thinking more about the problem, that seems to be the case. David
>>Brownell already told me that.
>>
>>I sent him an e-mail telling what I see when I modify my
>>/etc/hotplug/usb.rc script to contain "modprobe -q uhci-hcd debug=2".

He never got it, and the webpages you put up with that info didn't
have that information either. Please just keep the list updated;
I don't have much time for such things.

And for that matter, all followups _only_ to linux-usb-devel please!
This discussion shouldn't be CC'd to three large lists (IMO).



>>> hub 2-2.2:1.0: transfer --> -75
>>>
>>>indicates a problem with the internal hub, but there's no way to tell what
>>>that problem is. The other error message
>>
>>Is there any way to discover what may be the reason of the problem? Any
>>higher debugging level would help with that?

The message only comes out in one place (drivers/usb/core/hub.c),
so there's only one way it could appear...

Clearly this external hub is misbehaving, that should never happen.
Maybe it needs more power than it's getting.

However, even if the hub driver does see a fault, that's no excuse
for khubd to lock up.

- Dave


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:58    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site