lkml.org 
[lkml]   [2003]   [Oct]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: mptbase module problem on 2.6
    On Tue, 07 Oct 2003 09:15:58 +0200 Roelf Schreurs <rosc@imc.nl> wrote:

    | Hi
    |
    | I'm having trouble with the mptbase module.
    | This is what I do and the error I get.
    |
    | xconfig - Fusion MPT device support - all is selected as modules
    | make bzImage
    | make modules
    | ...
    | CC [M] drivers/message/fusion/mptbase.o
    | CC [M] drivers/message/fusion/mptscsih.o
    | CC [M] drivers/message/fusion/mptctl.o
    | CC drivers/message/fusion/mptbase.mod.o
    | LD [M] drivers/message/fusion/mptbase.ko
    | CC drivers/message/fusion/mptctl.mod.o
    | LD [M] drivers/message/fusion/mptctl.ko
    | CC drivers/message/fusion/mptscsih.mod.o
    | LD [M] drivers/message/fusion/mptscsih.ko
    | ...
    | make modules_install
    | ...
    | depmod: mpt_register_ascqops_strings
    | depmod: mpt_deregister_ascqops_strings
    | depmod: *** Unresolved symbols in
    | /lib/modules/2.6.0-test6/kernel/drivers/message/fusion/mptctl.ko
    |
    | depmod: mpt_free_fw_memory
    | depmod: mpt_reset_deregister
    | depmod: mpt_free_msg_frame
    | depmod: mpt_register
    | depmod: mpt_HardResetHandler
    | depmod: mpt_put_msg_frame
    | depmod: mpt_add_sge
    | depmod: mpt_GetIocState
    | depmod: mpt_alloc_fw_memory
    | depmod: mpt_reset_register
    | depmod: mpt_verify_adapter
    | depmod: mpt_send_handshake_request
    | depmod: mpt_deregister
    | depmod: mpt_get_msg_frame
    | depmod: mpt_config
    | depmod: *** Unresolved symbols in
    | /lib/modules/2.6.0-test6/kernel/drivers/message/fusion/mptscsih.ko
    |
    | depmod: mpt_adapter_find_first
    | depmod: mpt_print_ioc_summary
    | depmod: mpt_reset_deregister
    | depmod: mpt_event_deregister
    | depmod: mpt_free_msg_frame
    | depmod: mpt_register
    | depmod: mpt_HardResetHandler
    | depmod: mpt_put_msg_frame
    | depmod: mpt_v_ASCQ_TablePtr
    | depmod: mpt_add_sge
    | depmod: mpt_read_ioc_pg_3
    | depmod: mpt_ASCQ_TableSz
    | depmod: mpt_GetIocState
    | depmod: mpt_adapter_find_next
    | depmod: mpt_reset_register
    | depmod: mpt_event_register
    | depmod: mpt_ScsiOpcodesPtr
    | depmod: mpt_send_handshake_request
    | depmod: mpt_deregister
    | depmod: mpt_get_msg_frame
    | depmod: mpt_config
    |
    | INSTALL drivers/message/fusion/mptbase.ko
    | ...
    |
    | mkinitrd /boot/initrd-2.6.0-test6 2.6.0-test6
    | ([root@magelhaen kernel2.6]# ls -l /lib/modules/
    | total 4
    | drwxr-xr-x 4 root root 1024 Oct 3 19:49 2.4.18-3
    | drwxr-xr-x 4 root root 1024 Oct 6 12:44 2.4.18-3debug
    | drwxr-xr-x 4 root root 1024 Oct 3 19:49 2.4.18-3smp
    | drwxr-xr-x 3 root root 1024 Oct 7 09:01 2.6.0-test6
    | )
    |
    | No module mptbase found for kernel 2.6.0-test6 - This is the problem.
    |
    | using linux-2.6.0-test6.tar on Red Hat Linux release 7.3 (Valhalla)

    Hi,

    I don't see this problem in 2.6.0-test6.

    Are you using the latest/current module-init-tools (and not modutils
    from Linux 2.4)?

    What does 'depmod -V' report?

    module-init-tools are found at
    http://www.kernel.org/pub/linux/kernel/people/rusty/modules/

    --
    ~Randy
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:49    [W:0.055 / U:1.188 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site