lkml.org 
[lkml]   [2003]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectRe: Elevator bug in concert with usb-storage
    Mike Anderson writes:
    > Fredrik Tolf [fredrik@dolda2000.com] wrote:
    > > Sorry, that didn't work well. It doesn't crash on the same thing
    > > anymore, but nonetheless crashes. In addition, when I have removed the
    > > device but not yet umounted the filesystem, I tried to ls its root
    > > dir. Before, nothing extraordinary happened then, but now there's a
    > > couple of oopses for the ls process as well.
    > >
    > > .. snip ..
    > >
    > > Call Trace:
    > > [<c02176b3>] elv_queue_empty+0x1d/0x20
    > > [<c0219ab4>] __make_request+0x80/0x4ae
    > > [<c021a016>] generic_make_request+0x134/0x186
    >
    > I tried to reproduce this error last night using the scsi_debug driver,
    > but could not. I tried different combinations of file systems (fat, ext2,
    > ext3). I did notice that I had elevator=deadline on the cmdline. I
    > removed this in case the elevator_queue_empty_fn between the two
    > elevators made a difference. I still was unable to reproduce. I will try
    > a few more combinations of things this weekend and let you know what I
    > find out. There might be a race still with our cleanups and I am not
    > able to reproduce it exactly on my system.

    Be aware that this was with usb-storage as the back-end driver. I
    don't know if that might make some difference (as opposed to using
    scsi_debug, that is).

    Is there anything I can do to help?

    Fredrik Tolf

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:58    [W:0.020 / U:29.980 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site