lkml.org 
[lkml]   [2002]   [Sep]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] BUG(): sched.c: Line 944

On 17 Sep 2002, Robert Love wrote:

> OK so do we want to do (a):
>
> (moved down to after the preempt_disable() and release_kernel_lock())
>
> if (likely(current->state != TASK_ZOMBIE)
> if (unlikely((preempt_count() & ~PREEMPT_ACTIVE) != 1))
> ...
>
> or go with (b) where we split schedule() into schedule(),
> exit_schedule(), and do_schedule().

i'd do (a). current->state is to be used anyway, and the default-untaken
first branch should be cheap. Plus by moving things down the splitup of
the function would create more code duplication than necessery i think.

Ingo

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.122 / U:1.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site