lkml.org 
[lkml]   [2002]   [Aug]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: 2.4.20-pre2-ac3 stops responding
    Rik van Riel wrote:
    >
    > On Fri, 16 Aug 2002, Jean-Luc Coulon wrote:
    >
    > > 2nd while running:
    > > ------------------
    > > If I have high disk activity, the system stops responding for a while,
    > > it does not accepts any key action nor mouse movement. It starts running
    > > normally after few seconds.
    >
    > I've got a patch that might help improve this situation:
    >
    > http://surriel.com/patches/2.4/2.4.20-p2ac3-rmap14
    >
    > Could you please try this patch ?
    >
    > kind regards,
    >
    > Rik
    > --
    > Bravely reimplemented by the knights who say "NIH".
    >
    > http://www.surriel.com/http://distro.conectiva.com/

    I've applied the patch, it does not improve the things.
    The problem seems to be related with a DMA :
    [root@debian-f5ibh] ~ # hdparm -iv /dev/hda2

    /dev/hda2:
    multcount = 1 (on)
    IO_support = 1 (32-bit)
    unmaskirq = 0 (off)
    using_dma = 0 (off)
    keepsettings = 0 (off)
    readonly = 0 (off)
    readahead = 8 (on)
    geometry = 3649/255/63, sectors = 29302560, start = 9767520
    HDIO_GET_IDENTITY failed: Invalid argument

    [root@debian-f5ibh] ~ # hdparm -d1 /dev/hda2

    /dev/hda2:
    setting using_dma to 1 (on)
    HDIO_SET_DMA failed: Invalid argument
    using_dma = 0 (off)


    ----
    Regards
    Jean-Luc
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:28    [W:0.024 / U:1.196 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site