lkml.org 
[lkml]   [2002]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Linux 2.4.19-rc1-ac3
    On Sun, Jul 14, 2002 at 05:19:54PM +0200, Peter Osterlund wrote:
    > Dominik Brodowski <devel@brodo.de> writes:
    >
    > I tried speedstep but it didn't work because of this check in
    > speedstep_detect_processor:
    >
    > /* Intel Pentium 4 Mobile P4-M */
    > if (c->x86_model != 2)
    > return 0;
    >
    > if (c->x86_mask != 4)
    > return 0; /* all those seem to support Enhanced
    > SpeedStep */
    >
    > My cpu has model == 1 and mask == 2.
    Strange: According to the Intel docs (24919923.pdf and 25072104.pdf) as of
    June 2002, all P4-Ms have models have model "2" and mask "4", and none have
    model "1" and mask "2". What does /proc/cpuinfo say? And are you really sure
    it is a speedstep-capable P4-M?

    I'm really doubtful of that, as the MSR_EBC_FREQUENCY_ID didn't change a bit
    while trying speedstep transitions:

    > cpufreq: P4 - MSR_EBC_FREQUENCY_ID: 0x8a01fe00 0x0
    <snip>
    > cpufreq: P4 - MSR_EBC_FREQUENCY_ID: 0x8a01fe00 0x0


    > cpufreq: currently at low speed setting - 13800 MHz
    Obviously, this value is bogus, what's the correct CPU frequency of your
    notebook?

    > So what can I do to make speedstep work? According to the notebook
    > manual, speedstep is supported on this computer.
    How old is it? Fresh-out-of-the-factory? Then there might, just might be
    some update to the P4 specifications not yet included in the documentation.
    And please send me a /proc/cpuinfo, just to make sure. And, BTW, have you
    tried ACPI and its "performance state" interface?

    Dominik
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:27    [W:0.025 / U:60.672 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site