[lkml]   [2002]   [May]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: 2.5.11 and smbfs
On Tue, 30 Apr 2002, Scott A. Sibert wrote:

> I can mount other samba shares fine (ie. Samba-2.2.2 from OSX 10.1.4 and
> Samba-2.2.2 from Tru64 5.1) and the directories look fine. When I mount
> a share from a Windows 2000 server I only get the first letter of the
> entry in the shared folder which, of course, makes no sense and
> generates errors when just trying to get an "ls" of the share. The
> Win2K servers are both regular server and Adv Server, both with SP2 and
> the latest patches. The linux machine is running RedHat 7.2 with almost
> all of the latest updates and 2.5.11 compiled.

The server is returning unicode filenames but smbfs isn't expecting them.

You don't say which samba version your smbmount is from, but I'm guessing
2.2.1/2.2.2. They always negotiate unicode support without knowing if
smbfs supports it or not, which is a bug.

With smbfs unicode support in 2.5 this started to matter for various
reasons. I have thought about "autodetection" and maybe that will be
necessary anyway.

For now, upgrading samba to 2.2.3a should fix this. Let me know if it


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:25    [W:0.044 / U:3.068 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site