lkml.org 
[lkml]   [2002]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.4.20-ac1
On Sat, Nov 30, 2002 at 02:47:16AM +0200, Jarno Paananen wrote:

> > Linux 2.4.20-ac1
> > o VIA KT400 AGP support (Nicolas Mailhot)
> This doesn't seem to work on my setup, dmesg says:
> agpgart: unable to determine aperture size.
> My machine has A7V8X motherboard with KT400 chipset and Radeon 9700
> Pro running AGP 8X with sidebanding and fast-writes in Windows XP
> so the setup itself should be ok.
> I checked the code out a bit and the register supposed to be
> containing the aperture size contains 0x1b while the values in the
> array it is tested against are 0, 128, 192, 224, 240, 248 and 252
> (192 being 64 megs)... Could this be caused by AGP 3.0 or something
> that VIA handles differently than before? Anything else I could
> test or help get it to work?

I hadn't realised that was an AGP 3.0 chip. Its likely that we'll
need to change things to use different routines than the generic
ones if this is the case. If it is the case, then it shouldn't be too
hard to figure out what to change, as long as VIA have the specs
available.. I'll dig around when I get back on Monday.

Dave

--
| Dave Jones. http://www.codemonkey.org.uk
| SuSE Labs
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:31    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site