lkml.org 
[lkml]   [2002]   [Nov]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4.20-rc3 ext3 fsck corruption -- tool update warning needed?
On Wed, Nov 27, 2002 at 07:55:48AM -0500, Theodore Ts'o wrote:

> Ah, ha. I think I know what happened.
>
> What version of e2fsprogs were you using? If it was 1.28, that would
> explain what you saw. There was a fencepost error that could corrupt
> directories when it was optimizing/rehashing them. This bug was fixed
> in in the next version, which was rushed out the door as a result of
> this bug. Fortunately, 1.28 didn't get adopted by any distro's as far
> as I know

Hmm. On a recently installed SuSE 8.1 machine:

% rpm -qf `which e2fsck`
e2fsprogs-1.28-18

(maybe the -18 contains the fix?)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:31    [W:0.040 / U:9.016 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site