[lkml]   [2002]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [parisc-linux] Untested port of parisc_device to generic device interface
    On Wednesday 13 November 2002 12:52 am, Greg KH wrote:
    > On Wed, Nov 13, 2002 at 04:46:58PM +0900, Miles Bader wrote:
    > > Greg KH <> writes:
    > > > What is the real reason for needing this, pci_alloc_consistent()? We
    > > > have talked about renaming that to dev_alloc_consistent() in the past,
    > > > which I think will work for you, right?
    > >
    > > This this would end up [or have the ability to] invoking a bus-specific
    > > routine at some point, right? [so that a truly PCI-specific definition
    > > could be still be had]
    > If that was needed, yes, we should not break that functionality.
    > Are there any existing archs that need more than just dma_mask moved to
    > struct device out of pci_dev? Hm, ppc might need a bit more...

    Absolutely. Boxes with multiple IOMMUs (at least ia64, sparc64, parisc)
    need to look up the correct IOMMU with which to map the allocated buffer.
    Typically this is in the pci_dev sysdata.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:31    [W:0.019 / U:1.144 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site