lkml.org 
[lkml]   [2002]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.5.4[3-5] usb problems
On Fri, Nov 01, 2002 at 09:27:51AM -0500, Matthew Harrell wrote:
>
> A few different problems. First, when I use my USB hub then I get this
>
> drivers/usb/core/hub.c: new USB device 00:11.2-1, assigned address 2
> drivers/usb/core/hub.c: USB hub found at 1
> drivers/usb/core/hub.c: 9 ports detected
> drivers/usb/core/hub.c: new USB device 00:11.2-1.4, assigned address 3
> drivers/usb/core/hub.c: USB hub found at 1.4
> drivers/usb/core/hub.c: 3 ports detected
> drivers/usb/core/hub.c: new USB device 00:11.2-1.7, assigned address 4
> drivers/usb/core/hub.c: new USB device 00:11.2-1.8, assigned address 5
> drivers/usb/input/hid-core.c: ctrl urb status -32 received
> drivers/usb/input/hid-core.c: usb_submit_urb(ctrl) failed
>
> and none of the USB devices show up at all. But, when I plug the keyboard
> and mouse in without the hub they work fine.

I'm seeing some strange USB hub issues here too (hubs that work fine on
2.4, not working on 2.5, hubs that only work on boot, but not attaching
later), so you aren't alone.

It's time now for some serious USB debugging to get on, now that we have
the main feature freeze done.

thanks,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:30    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site