lkml.org 
[lkml]   [2002]   [Oct]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [Kernel 2.5] Qlogic 2x00 driver
    On 10/17/02 11:12, GrandMasterLee wrote:
    > On Wed, 2002-10-16 at 11:49, Michael Clark wrote:
    >>Seems to be the correlation so far. qlogic driver without lvm works okay.
    >>qlogic driver with lvm, oopsorama.
    >
    >
    > Michael, what exactly do your servers do? Are they DB servers with ~1Tb
    > connected, or file-servers with hundreds of gigs, etc?

    My customer currently has about 400Gb on this particular 4 node Application
    cluster (actually 2 x 2 node clusters using kimberlite HA software).

    It has 11 logical hosts (services) spread over the 4 nodes with services such
    as Oracle 8.1.7, Oracle Financials (11i), a busy openldap server, and busy
    netatalk AppleShare Servers, Cyrus IMAP server. All are on ext3 partitions
    and were previously using LVM to slice up the storage.

    The cluster usually has around 200-300 active users.

    We have had oops (in ext3) on differing logical hosts which where running
    different services. ie. has oopsed on the node mastering the fileserver,
    and also on the node mastering the oracle database.

    Cross fingers, since removing LVM (which was the only change we have made,
    same kernel) we have had 3 times our longest uptime and still counting.

    By the sounds, from earlier emails I had posted, users had responded
    to me who were also using qlogic and none of them had had any problems,
    the key factor was none of them were running LVM - this is what made
    me think to try and remove it (it was really just a hunch). We had
    gone through months of changing kernel versions, changing GigE network
    adapters, driver versions, etc, to no avail, then finally the LVM removal.

    Due to the potential nature of it being a stack problem. The problem
    really can't just be pointed at LVM but more the additive effect this
    would have on some underlying stack problem.

    I believe the RedHat kernels i tried (rh7.2 2.4.9-34 errata was the most
    recent) also had this 'stack' problem. I am currently using 2.4.19pre10aa4.

    I would hate to reccomend you remove LVM and it not work, but i
    must say it has worked for me (i'm just glad i didn't go to XFS instead
    of removing LVM as i did - as this was the other option i was pondering).

    ~mc

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:30    [W:0.031 / U:59.128 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site