lkml.org 
[lkml]   [2001]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Linux 2.4.10-pre11
    On Fri, Sep 21, 2001 at 01:03:40AM +0200, Andrea Arcangeli wrote:
    > What do you prefer for the next 2.4.10 mainline? I'd like to have this

    Famous last words, after a few hours of debugging mixed with vm patches
    and emails, I finally got around finding the real bug. The fact is that
    the secure-ramdisk logic was totally broken, not just for initrd, oh
    well, so please don't apply such patch (code in mainline has the
    security issue if you allow an luser to read from /dev/ram0, but it
    isn't buggy). and the issue is quite unfixable with just a PageSecure
    set inside rd.c. The fact is that I cannot just clear-around the
    written "bh", around there could be the source for the next block to
    write and I cannot zero it out. It is getting harder to fix this one
    just inside the ->make_request callback... Hints?

    Andrea
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:17    [W:0.023 / U:0.632 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site