lkml.org 
[lkml]   [2001]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] add kmalloc check in drviers/pcmcia/rsrc_mgr.c (245-ac16)
Em Sat, Jun 23, 2001 at 07:09:37PM +0200, Eric Lammerts escreveu:
>
> On Sat, 23 Jun 2001, Rasmus Andersen wrote:
>
> > + if (!b) {
> > + printk(" -- aborting.\n");
> > + printk(KERN_ERR "Out of memory.");
> > + return;
> > + }
>
> Why not printk(KERN_ERR "rsrc_mgr: Out of memory.\n"); ?
> Then at least people will know what it was that ran out of memory.

Better yet:

printk(KERN_ERR __FUNCTION__ "Out of memory.");

Then if you move the code to other function or if you change the name of
the function you don't have to go all over the code doing
s/old_function_name/new_function_name/g

- Arnaldo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.042 / U:0.072 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site