[lkml]   [2001]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Linux 2.4.4-ac10
    On Thu, May 17, 2001 at 09:40:39PM +0300, Matti Aarnio wrote:
    > On Thu, May 17, 2001 at 08:33:36PM +0200, Udo A. Steinberg wrote:
    > > With 2.4.4-ac10 and binutils 2.11 I get the following warnings:
    > It is a warning about kernel code using assembler statements
    > which are not valid with some older assemblers.

    Naeh, I am confusing (you, and myself). Fixing those (adding the '*')
    would not work with some older assemblers.

    Claiming minimum level of 2.10/2.11 for assembler/binutils would
    certainly allow fixing things by adding the missing '*'.

    > > gcc -D__KERNEL__ -I/usr/src/linux-2.4.4-ac/include -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -march=i686 -malign-functions=4 -c -o pci-pc.o pci-pc.c
    > > pci-pc.c:964: warning: `pci_fixup_via691' defined but not used
    > > pci-pc.c:977: warning: `pci_fixup_via691_2' defined but not used
    > > {standard input}: Assembler messages:
    > > {standard input}:747: Warning: indirect lcall without `*'
    > > {standard input}:832: Warning: indirect lcall without `*'
    > > {standard input}:919: Warning: indirect lcall without `*'
    > > {standard input}:958: Warning: indirect lcall without `*'
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 12:53    [W:0.020 / U:15.176 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site