lkml.org 
[lkml]   [2001]   [Apr]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subjectmysqld [3.2.23] hangs when key_buffer ~256MB on [2.4.2-ac28+]
    Date
    I initially upgraded my kernel from 2.4.2-ac5 to 2.4.3 and the first thing I
    noticed was that mysqld was stuck. Killing it left it hanging in a D state.
    Then I tried 2.4.2-ac28 (which I am using now), and the got the same result.

    My key_buffer was set to 256MB, so I figured maybe it was something to do
    with memory usage so I lowered that figured to 128MB and restarted the
    system to clear the D state procs. Everything works fine now. 2.4.2-ac5
    did not have issues with the larger key_buffer.

    Can anyone reproduce this problem?

    --
    Vibol Hou
    KhmerConnection, http://khmer.cc
    "Connecting Cambodian Minds, Art, and Culture"

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:23    [W:0.027 / U:60.096 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site