[lkml]   [2001]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: opl3sa not detected anymore
    On Mon, 12 Feb 2001, Chris Funderburg wrote:

    > After the updates to the opl3sa2 driver (2.4.2-pre3?) my card isn't being
    > detected anymore. Are there further updates to come, or do I need to
    > change the settings? The driver is being loaded as a module with the
    > following in /etc/modules.conf:
    > The midi works fine, but 'modprobe sound' reports:
    > opl3sa2: No cards found
    > opl3sa2: 0 PnP card(s) found.

    If you've configured ISA PnP support into the kernel, then the driver
    ignores those settings unless you specify isapnp=0. What I'd suggest
    is that you try disabling the configuration done by the isapnp tools,
    which can be done on RedHat and derived systems by renaming your
    /etc/isapnp.conf to something else. There seem to be some issues
    with resetting the PnP configuration with isapnp after the in-kernel
    ISA PnP driver has done its stuff, as a couple of other people have
    mentioned similiar problems.


    Scott Murray email: (coming soon) ICQ: 10602428
    "Good, bad ... I'm the guy with the gun." - Ash, "Army of Darkness"

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:13    [W:0.020 / U:4.224 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site