lkml.org 
[lkml]   [2001]   [Dec]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: question about kernel 2.4 ramdisk

At 05 Dec 2001 09:23:03 +0100,
Christoph Rohland wrote:
>
> Hi Tachino,
>
> On Wed, 05 Dec 2001, Tachino Nobuhiro wrote:
> > + if (!strcmp(optname, "maxfilesize") && value) {
> > + p->filepages = simple_strtoul(value, &value, 0)
> > + / K_PER_PAGE;
> > + if (*value)
> > + return -EINVAL;
> > + } else if (!strcmp(optname, "maxsize") && value) {
> > + p->pages = simple_strtoul(value, &value, 0)
> > + / K_PER_PAGE;
> > + if (*value)
> > + return -EINVAL;
> > + } else if (!strcmp(optname, "maxinodes") && value) {
> > + p->inodes = simple_strtoul(value, &value, 0);
> > + if (*value)
> > + return -EINVAL;
> > + } else if (!strcmp(optname, "maxdentries") && value) {
> > + p->dentries = simple_strtoul(value, &value, 0);
> > + if (*value)
> > + return -EINVAL;
> > + }
>
> Please! If you do the limit checking for ramfs adapt the same options
> like shmem.c i.e. size,nr_inodes,nr_blocks,mode(+uid+gid). Don't
> invent yet another mount option set. Also give them the same
> semantics. Best would be to use shmem_parse_options.

These options are not my invention. Ramfs in 2.4.13-ac7 already has them.
But I agree the original options are not easy to understand, so if compatibility
does not matter, I am glad to change them.


> Further thought: Wouldn't it be better to add a no_swap mount option
> to shmem and try to merge the two? There is a lot of code duplication
> between mm/shmem.c and fs/ramfs/inode.c.
>

I thought that too. but I don't know it should be done in stable kernel series.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.063 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site