lkml.org 
[lkml]   [2001]   [Dec]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] DRM 4.0 support for kernel 2.4.17
On Sun, Dec 23, 2001 at 10:48:36AM +1100, Keith Owens wrote:
> needs the separate copy of drmlib. I will not maintain that crud into
> kbuild 2.5.
>
> drivers/char/drm-4.0/Makefile below uses the standard kbuild design.
> One copy of drmlib-4.0 which is built into the kernel if any drm 4.0
> drivers are built in, otherwise drmlib-4.0 is a module if there are any
> drm 4.0 modules. Totally untested.

ftp.kernel.org/pub/linux/kernel/people/hch/patches/v2.4/2.4.17/linux-2.4.17-drm40-1.patch.bz2

Is a version that is (build-) tested and very similar to your versions, based
on my 2.4.0-test Makefile.

> Some of the code in $(drmlib-4.0-objs) will need EXPORT_SYMBOLS to work
> when drm 4.0 drivers are compiled as modules.

I don't consider that a good use of drm 4.0. If someone wants to fix it
anyway he/she should do it. I don't think this compatiblity code needs
so much attention.

Christoph

--
Of course it doesn't work. We've performed a software upgrade.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:14    [from the cache]
©2003-2011 Jasper Spaans