lkml.org 
[lkml]   [2001]   [Dec]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: file corruption in 2.4.16/17

    Christian,

    Don't take the tone personally, it is directed at the primary kernel
    maintainers.

    Well I will promise you that it is not my driver! Additionally there has
    been a private blanket test to authenticate it is doing the correct thing.
    Now the legacy driver in the stock kernels have the ablitity to fail but
    very rarely.

    So I suggest you use a corrected driver found at www.linuxdiskcert.org.

    There will be an update for 2.4.17, but if you choose the use the legacy
    driver and you have FSC, TOUGH! I have offered out a tested and domain
    validated driver and nobody wants it.

    Regards,

    Andre Hedrick
    CEO/President, LAD Storage Consulting Group
    Linux ATA Development
    Linux Disk Certification Project


    On Sat, 22 Dec 2001, Christian Ohm wrote:

    >
    > hi.
    >
    > i've recently bought a new 80gb ide drive, and am now getting corrupted
    > files on it. i've made three partitions for linux on it, a small ext2 one as
    > root, and two larger ones with reiserfs as /usr and /var. the problem is
    > that now some files get randomly corrupted; they are the right size, but
    > contain some random garbage (searching the archive for this list just came
    > up with some issues around july / kernel 2.4.6), which makes the system
    > pretty much unusable.
    >
    > my old setup with a 20gb ide drive and a 4.5gb scsi drive worked flawlessly
    > for at least a year with reiserfs, so this seems to be a problem with
    > reiserfs and large drives (i haven't found a corrupted file on the ext2
    > partition (yet)). my hardware is: a nmc (now enmic) 8tax+ mainboard with via
    > kt133 chipset (newest bios), a maxtor d540x-4k 80gb harddrive and a quantum
    > lct15 20gb harddrive. i used kernel 2.4.16 with the preemtion patch, but
    > 2.4.17 seems to have the same problem.
    >
    > windows had a problem with the maxtor drive, too. i made a fat32 partition
    > and copied the files from the old drive under linux. worked perfectly, but
    > when reading the partition with windows, it showed a corrupted file system.
    > i had to install a special ide driver not included in the via 4in1 drivers
    > to read it correctly, but now it works without problems.
    >
    > i'd be happy if there's a solution for this, as, like i said, the system now
    > is pretty much unusable.
    >
    > bye
    > christian ohm
    >
    > ps.: i'm not subscribed to this list, so please cc me on any replies to this
    > thread. thanks.
    > -
    > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    > the body of a message to majordomo@vger.kernel.org
    > More majordomo info at http://vger.kernel.org/majordomo-info.html
    > Please read the FAQ at http://www.tux.org/lkml/
    >

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:14    [W:0.025 / U:60.816 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site