lkml.org 
[lkml]   [2001]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Problem with i820 AGP patch
    On Thu, Nov 15, 2001 at 09:01:54AM +0100, Nicolas Aspert wrote:
    > test... Can you send what 'lspci -ev' shows ?

    Here it is, I think I should have thought before...
    -ev didn't worked, I used -vn with a cut & paste for names (first line
    of each entry)

    00:00.0 Host bridge: Intel Corporation 82820 820 (Camino) Chipset Host Bridge (MCH) (rev 03)
    00:00.0 Class 0600: 8086:2501 (rev 03)
    Subsystem: 1043:801c
    Flags: bus master, fast devsel, latency 0
    Memory at d0000000 (32-bit, prefetchable) [size=256M]
    Capabilities: <available only to root>

    00:01.0 PCI bridge: Intel Corporation 82820 820 (Camino) Chipset PCI to AGP Bridge (rev 03) (prog-if 00 [Normal decode])
    00:01.0 Class 0604: 8086:250f (rev 03)
    Flags: bus master, 66Mhz, fast devsel, latency 0
    Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
    Memory behind bridge: cc000000-ccffffff
    Prefetchable memory behind bridge: cdf00000-cfffffff

    00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02) (prog-if 00 [Normal decode])
    00:1e.0 Class 0604: 8086:2418 (rev 02)
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
    I/O behind bridge: 0000c000-0000dfff
    Prefetchable memory behind bridge: cd000000-cdefffff

    01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04) (prog-if 00 [VGA])
    01:00.0 Class 0300: 102b:0525 (rev 04)
    Subsystem: 102b:0378
    Flags: bus master, medium devsel, latency 64, IRQ 11
    Memory at ce000000 (32-bit, prefetchable) [size=32M]
    Memory at cc800000 (32-bit, non-prefetchable) [size=16K]
    Memory at cc000000 (32-bit, non-prefetchable) [size=8M]
    Expansion ROM at cdff0000 [disabled] [size=64K]
    Capabilities: <available only to root>

    Other entries are all related to non-interesting (I think) devices (IDE, SMBus, audio, etc.)

    > It worked, but in which way ? Did you test X+OpenGL apps to see whether
    > it did the trick ? The fact that the module loads itself is not always
    > sufficient to say that it works (believe me :-)
    It loaded and glxgears worked correctly, I didn't tested other apps

    > With your custom patch, or with the 'generic' stuff ?
    Both (sigh!), the problem shows with or without your patch.
    Now I'm tring your new patch, but I don't think something will change.

    Regards.

    --
    -----------------------------------------------------
    Daniele Venzano
    Senior member of the Linux User Group Genova (LUGGe)
    E-Mail: venza@iol.it
    Web: http://digilander.iol.it/webvenza/
    LUGGe: http://lugge.ziobudda.net

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:13    [W:0.044 / U:1.168 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site