[lkml]   [2000]   [Aug]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    Subjectbad ext2fs corruption in 2.2.16
    I'm experiencing a problem on my laptop that is seemingly resulting in
    rapid, massive ext2fs corruption on an IDE drive. The problem seems to be
    correlated to use of "cdparanoia" to rip audio data from audio CDs to the
    hard drive. I'm running kernel 2.2.16 on a Dell Latitude CPi A366T. 366 MHz
    Pentium II, 128MB of RAM, 6GB hard drive.

    IDE controller and disk info:

    PIIX4: IDE controller on PCI bus 00 dev 39
    PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x0860-0x0867, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x0868-0x086f, BIOS settings: hdc:DMA, hdd:pio
    hda: IBM-DADA-26480, ATA DISK drive
    hdc: TOSHIBA CD-ROM XM-1902B, ATAPI CDROM drive
    ide2: ports already in use, skipping probe
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: IBM-DADA-26480, 6194MB w/460kB Cache, CHS=789/255/63, UDMA
    hdc: ATAPI 24X CD-ROM drive, 128kB Cache
    Uniform CD-ROM driver Revision: 3.09
    Partition check:
    hda: hda1 hda2 < hda5 hda6 >

    This system has been in service since June of '99 without any major
    disk-related problems (obviously some kernel upgrades). A few weeks ago, I
    ran 'cdparanoia' and had processes start crashing randomly, so I rebooted
    and fsck found lots of icky stuff. I was a little concerned, but after that
    it went for weeks without any more problems (including several manual fscks
    to be sure there wasn't more corruption creeping in). Today I ran
    'cdparanoia' to rip some audio and almost instantly programs started
    crashing again. Virtually everything I ran crashed with a seg fault. One of
    the directories I was working in lost all of its entries, including "." and
    "..". When the system came back up and fsck ran, there were lots and lots of
    problems. Dozoens of "duplicate/bad block(s) in inode n:", "unattached
    inode", "free blocks count wrong for group #n", etc. At one point there was
    a message which scrolled by so quickly I couldn't read it with hundreds or
    tousands of negative numbers (I'm assuming they were supposed to be block or
    inode numbers), followd by "fix <y>?" I had at least 10 files in /usr/local
    become corrupted. What was originally a tcl script was replaced with
    apparently random binary data. What was previously a shared library was
    replaced with data that begins:

    sse: ") ("signature" "Unterschrift: ") ("opening" "Anrede: ") ("closing" "Schlu\
    "s: ")] 15])
    #@58 Insert ENVIRONMENT and prompt for recipient and address.

    /lost+found has some interesting files in it:

    eris /lost+found
    9% ls -al
    total 4353701167
    c---rw--wx 1 16650 25963 32, 53 Oct 6 2023 #1162
    c--xrw--wx 1 25963 29541 32, 102 Apr 2 2029 #1163
    c---rwx-w- 1 29793 25710 10, 32 Apr 3 1987 #1165
    c--xrw-r-- 1 28532 8294 48, 32 Oct 6 2023 #1167
    br-xr-s-wx 1 28274 15717 54, 51 Aug 15 2027 #1168
    b--Sr-S--- 1 28009 14900 101, 110 Mar 24 1987 #813
    c---rw--w- 1 13360 22597 118, 101 Sep 19 2028 #814
    drwxr-xr-x 2 root root 12288 Aug 27 18:54 ./
    drwxr-xr-x 22 root root 1024 Jan 1 2000 ../

    I don't have strong evidence that cdparanoia is causing this. It just has
    been an awfully strange coincidence that both times the problem has
    happened, it has been immediately after I started cdparanoia. And I have
    seen absolutely no other disk-related problems.

    Any ideas on what's going on here? Ideas for more troubleshooting and



    Sean Harding |"Well, contempt loves the silence | It thrives in the dark"
    | --Natalie Merchant
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 12:38    [W:0.041 / U:6.204 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site